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Setting Up Your Account 
 
BROWSER SETUP  

 
This step will enable your browser to “allow” pop-up windows from NetSuite. (Such as 
completed certificates) 

Google Chrome   

1. Select the three dots in the upper right corner of the browser  
*This step will enable your browser to “allow” pop-up windows from NetSuite. (Such as 
completed certificates) 
 

 
 

2. Select “Settings” from the menu that appears 

 



 
 

 
 
 

3. Select “Privacy and Security” 

 
 

4. Select “Site Settings” 

 
 

5. Under Content > Select Pop-ups and redirects  

 
 

6. Select “Sites can send pop-ups and use redirects” 



 
 

 
 

7. Close the Setting Tab  

Firefox (Windows) 

1. Select the three horizontal bars in the upper right corner.  
2. Select Options.  
3. Select the Privacy and Security tab.  
4. To allow specific pop-ups, click Exceptions and enter the URL(s). 

https://6969186.app.netsuite.com/app/login/secure/enterpriselogin.nl?c=6969186&when
ce=   

5. Close the window. Click OK. 

Microsoft Edge  

1. In Edge, go to Settings and more (three dots) at the top of your browser. 

 

2. Select Settings > Cookies and site permissions. 
3. Under All permissions, select Pop-ups and redirects. 
4. Go the Allow section, and then select Add. 
5. Type in the URL that you want to allow to create pop-ups into the dialog box (starting 

with the https:// portion at the beginning) and select Add. The URL should now appear in 
your Allow list. 
https://6969186.app.netsuite.com/app/login/secure/enterpriselogin.nl?c=6969186&when
ce=  

 

You are now ready to set up your NetSuite Account  
 

The account set up process is the first step in ensuring that you have access rights to transact 
business in NetSuite. 

Once your NetSuite account has been activated, you will receive an automated email (sample 
below) to complete the account set up process.  

https://6969186.app.netsuite.com/app/login/secure/enterpriselogin.nl?c=6969186&whence
https://6969186.app.netsuite.com/app/login/secure/enterpriselogin.nl?c=6969186&whence
https://6969186.app.netsuite.com/app/login/secure/enterpriselogin.nl?c=6969186&whence
https://6969186.app.netsuite.com/app/login/secure/enterpriselogin.nl?c=6969186&whence


 
 
 

 

Click on the link “Please click here to set up your password”. Note: this password link is valid 
for 72 hours only.  

Note your login email address as you will require this to login along with your password. 

The link will take you to the NetSuite site.  

You will need to choose a new password that is a minimum of 10 characters and contains at 
least 3 of the following:  

 Uppercase letters 
 Lowercase letters 
 Numbers 
 Non-alphanumeric ASCII characters (! @ # % & * ^ , : ; ~ “ / \ + ? – [ ] { } < > )  

Once your password has been set, you can log into NetSuite with your email and password 

user@gfd.org 



 
 

 

The first time you log in to NetSuite, you will be required to complete a set of three security 
questions.   

These questions are used to verify your identity, should you forget your password or log in form 
a different computer.  

 

Your security questions can be updated at any time by clicking on the Update Security 
Questions in the Settings portlet on your Home dashboard. 



 
 

 

You are now ready to start using NetSuite  
 

Dashboard 
 
Top left hand side of your dash board is where you would log out, as well as view multiple 
locations if applicable.   

 
 
Click on the house icon at any stage within NetSuite to return to your Dashboard 

 
 
To start a new application, hover over Applications, then hover over Insurance then click on 
Insurance Application – New Business to start your application process.  Or choose Travel Plan 
Application 

 

 
 
For a list of all policies, hover over Certificates > Insurance Policies > Click on Insurance 
Policies (Do not click on Search)  
 



 
 

   
 
Too submit a generic support ticket, not related to a policy, hover over GFD Support > 
Insurance > click on Support Ticket  
 

 

 
Cases (Insurance) is a shortcut to process a Transfer and Cancel request. Hover over Cases 
(Insurance) > Insurance > Then click on Transfer or Cancel 

 

 
Claims (Insurance Mgr) is a quick shortcut to Submitting a Death Claim.  Hover over Claims 
(Insurance Mgr) > Insurance > Submit a Death Claim 

 
 

 
 
Policy Management:  

Insurance Policies – Link to all your policies  
Draft Insurance Applications – List of applications started but not yet submitted 
Open Cases – List of all cases  
 
 



 
 
Payouts:  
 
Claims Pending Payment – Claims submitted and pending payment 
Paid Cancellation – List of paid cancelled policies  
Paid Claims – List of all paid claims  

Deposits:  

New Business Deposits – List of all new business submitted 
Inforce Certificates – List of all active policies 
Policies Paid In Full – List of all paid in full policies with the ability to print Paid in Full letters 

Reports: 

New Business by Enroller – List of all new business submitted by Enroller  
 

List of Policies 
There are two way to navigate to your list policies 

• Shortcut under Policy Management > Insurance Policies  
• Certificates (Insurance Mgr) hover over along the top main tabs > click on Insurance Policies *Do 

Not click on Search 

•  
• Insurance Policies – Member View will open  
• Click on the + symbol next to the word FILTERS  

•  
• Click on the blue hyperlink policy number to open the policy 



 
 

•  
• Or you can use the filters to search for a specific policy 

•  

 

Online Application  
 
Submit a New Insurance Application with eSignature 
 

• To navigate to the Insurance Application: use the menu along the top of your homepage, 
hover over Applications > Insurance > Insurance Application – New Business 
 

• Here are some notes to help you through the online application as there are some 
changes 



 
 

 



 
 

 
 

*Email Field – If client does not have an email address, do not use the enroller’s email address. 
Each signee’s email address must be unique.  You can use a different email address associated 
to the funeral home (i.e. info@abcfuneralhome.ca)    



 
 

 
 
*Email Field – If client does not have an email address, do not use the enroller’s email address. 
Each signee’s email address must be unique.  You can use a different email address associated 
to the funeral home (i.e. info@abcfuneralhome.ca)      

 



 
 

 



 
 

 

 



 
 

 

At this point, you have finished entering all the information for the bulk of the application. On the 
review page you will find 

(1) A summary of the information you have input to this point,  

(2) Indicate a Power of Attorney and upload the supporting documents ONLY for POA, and  

(3) Terms and Conditions for Funeral Recipient and Purchaser to agree to. 



 
 

 

 

Fake Funeral Home 
123 Fake St.  
Oakville ON P0D7F2 
Canada 



 
 

 

Once you have hit save & continue, you will be taken to the following screen, which will allow 
you to update the email addresses if needed before selecting the eSign process that is 
applicable. 

*Email Field – If client does not have an email address, do not use the enroller’s email address. 
Each signee’s email address must be unique.  You can use a different email address associated 
to the funeral home (i.e. info@abcfuneralhome.ca)    

 

• Sign Now – best if ALL signees, including the enroller are present physically to sign the 
document right now in person. 

• Request Signature – best if that is not the case, each party will receive an email when it 
is their turn to sign the document. 

The signing order is determined by the inputs for the application, as follows: 
 
If Funeral Recipient is also the Purchaser 1. Funeral Recipient 

2. Enroller  
If Funeral Recipient is NOT the Purchaser 1. Funeral Recipient 

2. Purchaser 

User 123456789 



 
 

3. Enroller 
If POA Exists Power of Attorney signs on behalf of Funeral 

Recipient 
 

 

SIGN NOW STEPS 

1. Select Yes, then click Sign Now 

 

2. Confirm terms and conditions and click Ready to Sign 

 

3. For security purposes, drag the white cloud over the black cloud to begin the signing process 

(user@gfd.org) 



 
 

 

4. Check the box and Accept & Continue 

 

5. To begin signing the document, click the blue Begin button 



 
 

 

6. This will take you to the first location in the document, where you need to sign 

 

7. When you click on the signature, the following will pop-up – allowing you to choose if you want to type 
in your name to select a signature or draw your signature using a mouse or even on an iPad 

  

8. Once you adopt a Signature, this will be used on all the required signature areas.  
9. You will click next on the top of the screen, as there may be multiple signatures for the funeral recipient 

and / or purchaser. 



 
 

 

10. Once you are taken to the bottom of the document where it says “Continue” you can click that button, 
and this will take you back to the cloud authentication. 

 

11. Next the Enroller will have to sign. For security purposes, drag the white cloud over the 
black cloud to begin the signing process 
 



 
 

 
 
12. Check the box and Accept & Continue 

 

13. To begin signing the document, click the blue Begin button 



 
 

 

14. When you click on the signature, the following will pop-up – allowing you to choose if you 
want to type in your name to select a signature or draw your signature using a mouse or 
tablet 
 

 

15. Once you adopt a Signature, this will be used to sign the required field  
 

16. Click on the signature line to sign > Click Sign & Finish   



 
 

 

This concludes the Sign Now Application Process  

 

Click on the GFD Insurance by Funeral Plans Canada logo to return to the Home Page. 

 

REQUEST SIGNATURE STEPS (This process will be used when not all parties are available to sign) 

1. Select No > Request Signature  

User #123456789 



 
 

 
2. Each party will get an email once it is their turn to sign, the email will look something like 

this 
 

 

3. Once the blue Review button in the email is clicked, the internet browser will open up to 
the document that needs to be signed.  
 

4. Prior to being able to sign the document, the terms must be checked and agreed to 
 

 

5. To begin signing the document, click the blue Begin button 

User 

Fake Funeral Home Test Has Requested Your Signature On A Document 



 
 

 

6. This will take you to the first location in the document, where you need to sign 
 

 
 
7. When you click on the signature, the following will pop-up – allowing you to choose if you 

want to type in your name to select a signature or draw your signature using a mouse or 
even on an iPad 
 

  
 
8. You will click next on the top of the screen, as there may be multiple signatures for the 

funeral recipient and purchaser. Once you are taken to the bottom of the document 
where it says “Sign & Finish” you can click that button, and you have completed your 
part 
 



 
 

 

 
 

9. The next signee will now receive an email based on the signing order above, to sign. 

This concludes the Request Signature Process once all signatures are received.  

 
 

NOTES  

- Recipient SIN, along with Purchaser SIN is a mandatory field, we will be working to remove the 
Recipient SIN as mandatory into phase 2. 

- *Do not use the back button on browser, use the “Previous” button or tabs along the top of the 
application only, to toggle back and forth if required. 

 

Member Case Request  
• Navigate to the Insurance Policy List: Use the Certificates tab along the top of your 

home page, hover over Certificates > Insurance Policies - Insurance Policies *Do Not 
click on search 

 
• Navigate to a policy – Click on the blue policy number (hyperlink) 

 
• Or you can use the filters to search for a specific policy  

 
• When the policy opens, select the “Member Case Request” button along the top of the 

page 

Fake Funeral Home 

Fake Funeral Home 

Fake Funeral Home 



 
 

 
• Select a Case Type > Certificate Changes  

 
• Additional Information (mandatory field) please input instruction regarding request > 

Save 



 
 

 
• Case Successfully Saved > Case number provided  

 
• Files can be uploaded once your case has been saved 
• Choose File > PDF, Word, JPEG > Click to Upload 

 

•  

Fake Funeral Home 
 
ASSIGNED TO 

6971235 – 4978315 User - Member 

6971235 – 4978315 User – Member Case Request 

6971235 – 4978315 User – Member Case Request A Basic Service 2012 

Fake Funeral Home 
 
ASSIGNED TO 



 
 

 
• After uploading, the file name will be displayed   

 

 

This concludes “Submitting a Member Case Request” 

Death Claim 
*Proof of death required on all Foresters policies and all Equitable policies over 10K. 

• Navigate to the Insurance Policy List: Use the Certificates tab along the top of your 
home page, hover over Certificates > Insurance Policies - Insurance Policies *Do Not 
click on search 

 
• Navigate to policy – Click on the blue policy number (hyperlink) 

 
• Or you can use the filters to search for a specific policy  

 
• When the policy opens, select “Death Claim” at the top of the page   

Fake Funeral Home 
   

 
   

Fake Funeral Home 
   

 
   Fake Funeral Home 
   

 
   



 
 

 
• A new page will open, displaying your Death Claim Case  
• Within the death claim case you can also obtain a Death Benefit Quote    

•  
• Next you will enter a Death Date in the Death Claim section (this is a mandatory field) 

 
• Enter Additional Information (optional)  
• Click Save 

Fake Funeral Home 
 
ASSIGNED TO 
 
EMAIL(S) 
fake@gmail.com 



 
 

 
• A declaration will appear, which must be confirmed before proceeding. Click “OK” to 

continue 

 
• Attach proof of death *Proof of death required on all Foresters policies and all 

Equitable policies over 10K. 
• Files can be uploaded once your case has been saved 
• Choose File > PDF, Word, JPEG > Click to Upload 

 
 

• After uploading, the file name will be displayed   



 
 

 

This concludes “Submitting a Death Claim” 

 

 

 

Cancellation 
PLEASE NOTE: Cancellation letter will be required to be uploaded on all Foresters policies and all 
Equitable policies over 10K 

• Navigate to the Insurance Policy List: Use the Certificates tab along the top of your 
home page, hover over Certificates > Insurance Policies - Insurance Policies *Do Not 
click search 

 
•  Navigate to policy – Click on the blue policy number (hyperlink) 

 
 

• Or you can use the filters to search for a specific policy  

 
• When the policy opens, select “Cancellation” button at the top of the page  

Fake Funeral Home 
   

 
   Fake Funeral Home 
   

 
   

Fake Funeral Home 
   

 
   



 
 

•  
• Next you will indicate the method of payment, Pre-Authorized Debit or Personal Cheque 

•  
• For Pre-Authorized Debit, you will be required to enter the banking details 

•  
• Personal Cheque – A cheque will be mailed to the address on file 

 

•  
 

• To enter a different address, please select “Use Different Address” and provide the 
necessary details.  

Fake Funeral Home 
 
ASSIGNED TO 

6971235 – 4978315 User - Member 

6971235 – 4978315 User - Member 

EMAIL(S)* 
test@gft.com 



 
 

•  
• Enter any additional information (optional)  
• Files can be uploaded once your case has been saved 
• Click Save when done 

•  
• A declaration will appear, which must be confirmed before proceeding. Click “OK” to 

continue 

•  
• Once you confirm the declaration, you will receive confirmation of case number 
• Cancellation letter will be required to be uploaded on all Foresters policies and all 

Equitable policies over 10K 
 
Cancellation over 10K and Foresters policies  



 
 

•   
• Equitable policies under 10K 

•  
• Files can be uploaded once your case has been saved 
• Choose File > PDF, Word, JPEG > Click to Upload 

 
 

• After uploading, the file name will be displayed   

•  

This concludes the Cancellation process  



 
 

Transfer 
• Navigate to the Insurance Policy List: Use the Certificates tab along the top of your 

home page, hover over Certificates > Insurance Policies - Insurance Policies *Do not 
click on search 

 
•  Navigate to policy – Click on the blue policy number (hyperlink) 

 
 

• Or you can use the filters to search for a specific policy  

 
• When the policy opens, select “Transfer” button at the top of the page 

 
• Enter the Funeral Home name and address, to be transferred to (mandatory fields) 

 

Fake Funeral Home 
   

 
   Fake Funeral Home 
   

 
   

Fake Funeral Home 
   

 
   

6971235 – 4978315 User – Member Case Request Fake Funeral Home 
 
ASSIGNED TO 



 
 

• Enter Additional Information (optional)  
• Click Save 

 
 

• Case confirmation is created 

 
• Files can be uploaded once your case has been saved (optional) 
• Choose File > PDF, Word, JPEG > Click to Upload 

 

•  
 

6971235 – 4978315 User – Member Case Transfer Fake Funeral Home 
 
ASSIGNED TO 

6971235 – 4978315 User – Transfer Fake Funeral Home 2012 



 
 

 
 

• After uploading, the file name will be displayed   

•  

This concludes “Submitting a Transfer Request”   

Early Pay Out 
• Navigate to the Insurance Policy List: Use the Certificates tab along the top of your home page, 

hover over Certificates > Insurance Policies - Insurance Policies *Do Not click on search 

•  
• Navigate to policy – Click on the blue policy number (hyperlink) 
• Or you can use the filters to search for a specific policy  
• Click on the + symbol next to the word FILTERS if fields are not displayed 



 
 

•  
 

•  
• When the policy opens, select the “EPO” button along the top of your page 

•  
• A new page will open, displaying your EPO case.   
• EPO amount and admin fee will be displayed (Admin fee applies after 90 days)  

•  
• Select the method of payment 



 
 

•  
• Enter Additional Information (optional)  
• Click Save 

•  
• Case confirmation is created 

•  
• Files can be uploaded once your case has been saved (optional) 
• Choose File > PDF, Word, JPEG > Click to Upload 

 



 
 

•  
 

 
 

• After uploading, the file name will be displayed   

•  

This concludes processing an Early Payout 

Reduced Paid Up 
• Navigate to the Insurance Policy List: Use the Certificates tab along the top of your 

home page, hover over Certificates > Insurance Policies - Insurance Policies 

 
• Use the filters to search for a specific policy  



 
 

•  
•  Navigate to policy – Click on the blue policy number (hyperlink) 

 
• When the policy opens, select the “RPU” button along the top of your page 

•  
• A new page will open, displaying your RPU case.   

•  
• Enter current date for RPU value  

•  
• The account value displayed reflects the remaining balance on this policy  
• Enter Additional Information (optional)  
• Click Save 

Fake Funeral Home 
   

 
   Fake Funeral Home 
   

 
   

Fake Funeral Home 
   

 
   



 
 

•  
• Case confirmation is created 

•  
• Files can be uploaded once your case has been saved (optional) 
• Choose File > PDF, Word, JPEG > Click to Upload 

 

•  
 



 
 

 
 

• After uploading, the file name will be displayed   

•  

This concludes the process of a Reduced Paid Up 

Downgrade 
• Navigate to the Insurance Policy List: Use the Certificates tab along the top of your 

home page, hover over Certificates > Insurance Policies - Insurance Policies 

 
• Use the filters to search for a specific policy  

•  
•  Navigate to policy – Click on the blue policy number (hyperlink) 

 
• When the policy opens, select the “Downgrade” button along the top of your page 

•  

Fake Funeral Home 
   

 
   Fake Funeral Home 
   

 
   

Fake Funeral Home 
   

 
   



 
 

• A new page will open, displaying your Downgrade case.   

•  
• Enter the “New” Funeral cost 

•  
• Select the payment method to which funds will be returned 

•   
• Pre-Authorized Debit – Enter banking details 

•  
• Personal Cheque – Will be mailed to the address on file 



 
 

•  
• To use a different address, select “Use Different Address” and enter preferred address 

•  
• Enter Additional Information (optional)  
• Click Save 

•  
• Case confirmation is created 

•  
• Files can be uploaded once your case has been saved (optional) 
• Choose File > PDF, Word, JPEG > Click to Upload 

 



 
 

•  
 

 
 

• After uploading, the file name will be displayed   

•  

This concludes the process of a Downgrade  

 

 

Upgrade 
 

• Navigate to the Insurance Policy List: Use the Certificates tab along the top of your 
home page, hover over Certificates > Insurance Policies - Insurance Policies 

 
• Use the filters to search for a specific policy  



 
 

•  
•  Navigate to policy – Click on the blue policy number (hyperlink) 

 
• When the policy opens, select the “Upgrade” button along the top of your page 

•  
• A new page will open, displaying your Upgrade case 

•  
• Enter the “New” Funeral cost 
• *upgrade amount is a minimum of $500. Upgrade amount entered into Upgrade fields 

needs to be the Funeral Contract Amount + “Upgrade” amount. Example $5,000 funeral 
contract, upgrade $1,000 New Funeral Cost = $6,000 
 

•  
• Select the method of payment 

Fake Funeral Home 
   

 
   Fake Funeral Home 
   

 
   

Fake Funeral Home 
   

 
   

6971235 – 4978315 User – Member Case Request 
INSURANCE POLICY 
1002738 
 

Fake Funeral Home 
 
ASSIGNED TO 

EMAIL(S)* 
test@gft.com 



 
 

•  
• Pre-Authorized Debit – Enter banking details 

•  
• Personal Cheque – Will be applied once received  

•  
• Enter Additional Information (optional)  
• Click Save 

•  
• Case confirmation is created 



 
 

•  
• Files can be uploaded once your case has been saved (optional) 
• Choose File > PDF, Word, JPEG > Click to Upload 

 

•  
 

 
 

• After uploading, the file name will be displayed   

•  

This concludes the Upgrade process  

6971235 – 4978315 User – Member Case Request Fake Funeral Home 
 
ASSIGNED TO 



 
 

 

French Certificate  
• Navigate to the Insurance Policy List: Use the Certificates tab along the top of your 

home page, hover over Certificates > Insurance Policies - Insurance Policies 

 
•  Navigate to policy – Click on the blue policy number (hyperlink) 

 
 

• Use the filters to search for a specific policy  

 
• Once policy selected you will click on the French button  

•  
• Once the word French changes to English you can now print your French copy of the 

policy 
• Click the Printer Icon to open your policy in a new tab, where you can print a copy 

•  

 

 

 

 

 

 

 

Fake Funeral Home 
   

 
   Fake Funeral Home 
   

 
   

Fake Funeral Home 
   

 
   



 
 

Frequently Asked Questions: 
 

Question: How many staff members at our location will be able to access the new insurance 
system? 

Answer: There is currently a limit to two users per establishment, however if additional access 
is required, you can submit a support ticket or email to request access for additional users. 
Sharing logins is not best practice, for example, if you have someone leave the organization, 
you want to ensure they no longer have access to the confidential client information within your 
portfolio. Also when sharing access, only one person can be logged in at once, meaning that the 
online application and e-signature features can only be utilized by one individual during that 
time. 

All agents and enrollers will have their own login credentials. 

 

Question: Do claims need to be submitted by this system only or can they continue to be faxed 
in for processing? 

Answer: Claims should be submitted through NetSuite. This will also ensure that you will be 
paid out with greater efficiency. Fax copies will not be accepted. Please use the NetSuite 
platform to submit all requests associated with a policy. 

 

Question: Is this system also used for FPC now that they are combined? 

Answer: NetSuite is a new platform for FPC. We have rebranded our name to GFD Insurance 
by Funeral Plans Canada, under which both your Foresters (if applicable) and Equitable 
policies. 

 

Question: Will new business application and commission continue to be paid to the agent as 
they were previously? 

Answer: Business application will continue to be paid out to members and agents as they have 
been previously. The only changes, will now be, utilizing e-signatures for more efficient 
processing and the discontinuation of the 20% reserve on travel plan commission accounts, 
applicable only to insurance commission amounts. 

 

Question: What if the customer/client does not have an email? 

Answer: If the client is with you in person, you can use your own email address as they will be 
signing the application in person. If required, you can utilize the new version of the paper 
application to complete the application and email, fax or postal mail it to us for processing. 
Please note that this will take much longer to process. Using the new online application will 
allow your applications to be processed within a matter of hours and this will also ensure that 
you are able to meet commission deadlines. 



 
 
Question: In regard to month-end reporting, will/can the reports be broken down between 
company, now that they are all combined on one system? 

Answer: Month-end reports will continue to be separated by the insurer Foresters and 
Equitable. The only difference is, currently you may receive two reports for Foresters and one 
report for Equitable, moving forward you will have a single report for Foresters and a single 
report for Equitable. 

 

Question: As an existing NetSuite Trust Module user, when signing into NetSuite for the GFD 
Insurance by FPC Module, will it automatically sign-in the Trust and will we have to select either 
Trust or Insurance? 

Answer: As an existing NetSuite user, you will be able to view both Insurance and Trust using 
the same login. You will be able to toggle between locations if this is applicable to you, using the 
menu on the top right-hand side where you see your name. 

 

Question: Will both email address have access to all features such as reports? Currently one of 
our email addresses cannot access reports under GFD. Before NetSuite we used to get them 
emailed but not now, for quarterly commission. 

Answer: Only users with manager access will be able to view commission reporting. If you have 
a manager role (full access) for your Trust Module, you will be able to see all reports including 
commission reporting for Insurance. If you have an employee role (no report access) for your 
Trust Module, you will be able to see all reports for insurance except commission reporting. 

For quarterly Trust commissions, GFD will provide a confirmation letter upon request once the 
deposit is made. 

 

Question: Are people doing this data entry in NetSuite with the family present? From this last 
part, it sounds like the family can sign right then and there....do we no longer have to do any 
physical signatures if meeting the family in person? Can the application be completed in 
NetSuite with the family present? 

Answer: The online application in NetSuite allows you to choose from two e-signature options, 
the first is sign now and the second is request signature. You can fill out the application while 
your family is present and have them sign right there and then and you will not require any 
physical signatures. If you prefer to complete the application afterwards, you can choose the 
request signature option and the signees will receive an email when it is their turn to sign. Once 
all parties have signed, all signees will receive a completely executed agreement in their inbox.  

 

 

 

 



 
 
Question: Does the funeral director or enroller need to know about the emails for eSignatures 
in advance for sign now (sign in person) and request signature? 

Answer: If all parties will be at the appointment, the signatures can be done in person while 
submitting. However, if necessary, if a person is not there physically, then an email will be sent 
to them so they can action accordingly. If you are requesting signatures and completing the data 
entry without the clients, you will need to have the email addresses prior to requesting 
signatures. 

*If all parties are present and will be signing, the email is still required as this is a mandatory 
field. If the client does not have an email address, you can input your own as an option since the 
application will be signed on the spot, no emails will go out. 

 

Question: Will the EAAF no longer be required for New Business? 

Answer: The online application completed with e-signature eliminates the need for both the 
EAAF and PAD forms. A PAD form would still be required if you are completing an Early Payout 
(EPO) or need to update the bank withdrawal information on file, i.e. changing the withdrawal 
date from the 1st to the 8th. 

 

Question: When do credit card fees apply? 

Answer: We are pleased to offer you the option to allow your clients to pay with credit card for 
any pay plan. The online application will indicate when a credit card fee applies. There are no 
credit card fees applicable to the monthly payment plan from 3 to 15 years, all other options will 
indicate that a 2% processing fee applies. 

 

Question: Is it still possible to pay by Cheque or Deposit to RBC? 

Answer: Cheques are still accepted; however, they must be mailed with the completed, current 
version of the application and will require additional processing time due to manual processing. 
Please continue to make cheques payable to Equitable Life of Canada. Please note that deposit 
books are no longer accepted. Question: Member Case Requests – where does email 
communication go to? 

Answer: Email communication will go to the email address linked to the user, the email address 
will appear on your support ticket when created. This will apply to all case requests within 
NetSuite. 

 

Question: How do we handle families paying in cash? 

Answer: This would depend on the province as some province regulations do not allow a 
Funeral Home to make a payment to ELOC directly. 

 



 
 
Question: Can a funeral home still claim the Other Amount (DVO) Certificate? 

Answer: An AOB (Assignment of Benefits) form is still required to be provided as an attachment 
to the support ticket / case if funds on the “other amount” (DVO) are to be paid to the Funeral 
Home directly. 

 

Question: How do transfers to a Non-Member work? 

Answer: The current/original Funeral Home will submit the transfer request by submitting a 
transfer support ticket from the policy, and GFD Insurance by FPC will handle it as needed. 

 

Question: Credit Card fees and commissions. Are fees deducted from Commissions? 

Answer: Credit Card fees will be deducted from the commission amount. If commission funds 
are insufficient to cover the credit card fees, the remaining balance will be deducted from the 
next commission cycle. If commissions are unavailable for an extended period, an invoice will 
be generated. 
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